Member Log in
Email Address:
  Remember me
  Forgot your password?
  Not a member? Register Here

Q: Why do I need to register?

A: The original site "Dale & Adam's Track Schedule" covered the North East. It was strictly a text listing of the events, so you could only see all the events were posted. The new site is now National and covers all of North America. The site is 'database' driven, meaning that it can be customized by you to see exactly what you want to see. For example most of you will only want to see events within a certain distance of your location, say "North East" and "Eastern Canada". You may only want to see Driver's Education events or only see Racing events or something else. The new site lets you Filter what Regions, States and Tracks you want to see as well as the Event Types. You can also share your schedule with your Friends (that you will tell about the site and become registered too), so you can easily coordinate events together. In order for the site to 'remember' what your settings are, it needs to recognize you by your email address. So no matter where you are, at home, at work or at a friends you can log in using your email address, customize and mark up events to your hearts desire.

Q: I registered, but it doesn't login or the browser reports errors?

A: You must enable cookies in order to login to this site. A single cookie is used by the server to know you are a registered user, and its removed at the end of your browsing session. Also, several of the older web browsers do not work with modern web sites. Please download and install one of the browsers located on the "Home" page. We highly recommend Firefox.

Important note for IE 6.x users: You must have the "Run ActiveX controls and plug-ins" set to "Enable" in order for AJAX scripting controls to work. Most people do have this enabled, but a few don't and have problems setting the filters. If you have it disabled, you will get the error "Agent unable to establish communication". Look under: Tools -> Internet Options -> Security (tab) -> Custom Level (button). Then look under "ActiveX controls and plug-ins" and make sure that "Run ActiveX controls and plug-ins" is set to "Enable".